1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. You are currently not signed in. If you are already a registered user Please log in to get the full benefit from this site. If not, why not register and gain full access to our wonderful forums, view topics, make posts, and more! So if your not already a user, you can register by simply clicking the button to the right of this notice.

Electrical/alarm Issues On A Street Triple

Discussion in 'Mechanical' started by Jon Weston, Mar 12, 2017.

  1. Jon Weston

    Jon Weston Moderator Staff Member Moderator Site Supporter

    Messages:
    357
    I've had issues in the past with bad contact in the kill switch, and similar issues happened this morning resulting in failure to start. There was some crud on the contacts which was cleaned off but the bastered still didn't start.

    Noticed some random clicking coming from the alarm and that the light on the dash wasn't flashing as normal. It's serial number is not on the recall list but having my doubts now.

    Here are some vids if anyone notices anything familiar or can offer some advice:

    Alarm light flashing when ignition on and disarmed (does not usually do this) -

    Arming and disarming the alarm -

    Cheers for any advice, Jon
     
  2. Beelady

    Beelady Race Rep

    Messages:
    554
    Try a visit to the Street Triple Forum. Just about everything you might want to know about Striples is on there. Friendly, too. Sorry I don't know how to do a link but it comes up on Google.
     
  3. BlackHornet

    BlackHornet Look before you turn Staff Member Moderator

    Messages:
    6,991
    do you have a master key with the bike ?

    Be worth checking that just to make sure the code hasn't dropped off
     
  4. MaDProFF

    MaDProFF British Superbike

    Messages:
    2,186
    675.cc forum shed loads know everything too about Streets
     
  5. Mikey

    Mikey Off Roader

    Messages:
    140
    If you had bought cake back, it might not have happened that's all I'm saying lol
     
  6. MaDProFF

    MaDProFF British Superbike

    Messages:
    2,186
    Silly ? Is battery flat? I know you boight a new one last year, but when u last use it?
     
  7. Jon Weston

    Jon Weston Moderator Staff Member Moderator Site Supporter

    Messages:
    357
    It's on an optimiser - but will double check its not borked
     
  8. Jon Weston

    Jon Weston Moderator Staff Member Moderator Site Supporter

    Messages:
    357
    Was advised on a dedicated Street Triple forum to get a 'shorting plug' from Triumph to disconnect and disable the alarm from the ECU.

    Got one and fitted it and started first time, and then every time after! Reconnected the alarm and everything went wonky again. Definitely an alarm issue. Will get onto Datatool to get some advice.

    Have been out for a nice ride in the spring sunshine - lovely! :sun1:
     
  9. MaDProFF

    MaDProFF British Superbike

    Messages:
    2,186
    dam cold and windy more like :( just get a new bike :p
     
    Jon Weston likes this.
  10. Roadwart

    Roadwart Administrator Staff Member Administrator

    Messages:
    6,433
    Nice to know you may be getting somewhere Jon. :thumbsup:
     
    Jon Weston likes this.

Share This Page